Fix parsing error
1 min read

Fix parsing error

While tinkering around a ReactJS web project, I clone the same project again and start with yarn start, the compiling failed:

./src/firebase.config.js

Parsing error: Cannot find module './parse-with-scope'

It's the same project, such a mystery! Poking around the whole Internet with the error message, I found nothing. Out of desperation, I restarted my MacBook.This may not be helpful, but I haven't reboot my computer for some time anyway. I think I can clear the head of my computer in this way (or maybe I need to clear my head?).

Still, not working. OK, one last trick: delete the node_modules shit and yarn install again.

Magically, things start working.